Zengenti - Performance issues – Incident details

Performance issues

Resolved
Major outage
Started about 12 hours agoLasted 17 minutes
Updates
  • Resolved
    Resolved
    This incident has been resolved and we will issue an incident report to the affected clients in the next few days.
  • Investigating
    Investigating
    We are currently investigating an issue impacting some client services and our helpdesk.